Category Archives: Cisco 6880

So you really want to manually configure the 6800ia? It’s possible

Below is the command syntax to enable the fex configurations mode. First you will have to run “service internal” command, it will enable the hidden commands. However, do not forget to turn off the commands after making the changes using “no service internal”

6800-1#config t

6800-1(config)#service internal

6800-1(config)#exit

6800-1#test platform software console fex 110 enable timeout 60  <<<<< This command will enable configuration mode on fex 110 for 60 minutes

 

Once done with the changes on the fex110, run the following command on the parent switch to turn off the service internal mode:

6800-1#config t

6800-1(config)#no service internal

6800-1(config)#exit

Advertisements

Hit this bug on the 6880’s CSCuq46668

The official Cisco write up is here:
https://tools.cisco.com/bugsearch/bug/CSCuq46668/?reffering_site=dumpcr

The bug tool says it the know affected versions is 15.2(1)IC273.149  but I’m running Version 15.1(2)SY3.  I guess I’m running the wrong version of SY3 because this version 15.1(2)SY3.37 has the fix.

But this is what I was seeing that got me to talk with Cisco.  They originally said it was “cosmetic”.  But as you’ll see it’s not.

Nov 14 13:46:56.552: %SATMGR-SW2-5-FABRIC_PORT_UP: SDP up on interface Te2/5/5, connected to FEX 105, uplink 49
Nov 14 13:48:27.745: %SATMGR-SW2-5-FABRIC_PORT_DOWN: SDP down on interface Te2/5/6, connected to FEX 106, uplink 49 (reason: received non-vntagged packet)
Nov 14 13:48:35.285: %SATMGR-SW2-5-FABRIC_PORT_UP: SDP up on interface Te2/5/6, connected to FEX 106, uplink 49
Nov 14 13:50:53.990: %SATMGR-SW2-5-FABRIC_PORT_DOWN: SDP down on interface Te2/5/6, connected to FEX 106, uplink 49 (reason: received non-vntagged packet)
Nov 14 13:51:01.578: %SATMGR-SW2-5-FABRIC_PORT_UP: SDP up on interface Te2/5/6, connected to FEX 106, uplink 49
Nov 14 13:55:44.446: %SATMGR-SW2-5-FABRIC_PORT_DOWN: SDP down on interface Te2/5/6, connected to FEX 106, uplink 49 (reason: received non-vntagged packet)
Nov 14 13:55:51.991: %SATMGR-SW2-5-FABRIC_PORT_UP: SDP up on interface Te2/5/6, connected to FEX 106, uplink 49
Nov 14 14:03:27.677: %SATMGR-SW2-5-FABRIC_PORT_DOWN: SDP down on interface Te2/5/5, connected to FEX 105, uplink 49 (reason: received non-vntagged packet)

So the uplink is dropping because of a non-vntagged packet.  Since this is the 6800ia uplink everything on that link should be vntagged.  But since I have redundant uplinks it doesn’t drop off.

While trouble shooting this issue I also swapped SFP’s and I swapped ports on the 6800ia, and I swapped fiber.  Port 49 was always the uplink port that was reported in these logs.  So I thought it was a hardware problem.  But no it’s a bug.

They say it’s fixed in 15.1(2)SY4.  I’ll get it upgraded and post the results.

On a side note.  SDP stands for Satellite Discovery Protocol.  I’ll have to dig into that now.

Hit a bug on the new 6880’s with VSL dropping

Here are the log entries that indicate this Cisco bug ID CSCup99867 :

Nov 1 05:56:07.092: %VSLP-SW1-3-VSLP_LMP_FAIL_REASON: Te1/5/16: Timeout (30000msec) waiting for Hello packet from peer
.Nov 1 05:56:07.168: %VSLP-SW1-3-VSLP_LMP_FAIL_REASON: Te1/5/15: Timeout (30000msec) waiting for Hello packet from peer
.Nov 1 05:56:08.624: %VSLP-SW1-3-VSLP_LMP_FAIL_REASON: Te1/4/15: Timeout (30000msec) waiting for Hello packet from peer
.Nov 1 05:56:08.624: %VSLP-SW1-3-VSLP_LMP_FAIL_REASON: Te1/4/16: Timeout (30000msec) waiting for Hello packet from peer
.Nov 1 05:56:08.632: %VSLP-SW1-2-VSL_DOWN: All VSL links went down while switch is in ACTIVE role

I am running Cisco IOS Software, c6880x Software (c6880x-IPSERVICESK9-M), Version 15.1(2)SY3, RELEASE SOFTWARE (fc4)

To fix this issue you can adjust the timers with a hidden command on your VSL trunk links using the following command.

vslp int 500 min_rx 10000 multiplier 36

This command will increase the VSLP timeout from 60 to 360 seconds. The exact values of interval and min_rx I am still looking into.

(config-if)#vslp int ?

% Unrecognized command

Also if your console logging is not large enough or you can’t find log entries on your log server you can issue the following command:

more bootdisk:sea_console.dat

Be careful with that command it’ll dump a buffer of you logs to the screen but it’s a huge file. It’ll look like the following:

000005B0: 00000000 00000000 00000000 00000000 …. …. …. ….
000005C0: 00000000 00000000 31392E33 38373A20 …. …. 19.3 87:
000005D0: 254F4952 2D362D53 505F494E 53434152           %OIR -6-S P_IN SCAR
000005E0: 443A2043 61726420 696E7365 72746564 D:C       ard inse rted
000005F0: 20696E20 736C6F74 20312C20 696E7465             in slot 1, inte
00000600: 72666163 65732061 7265206E 6F77206F              rfac es a re n ow o
00000610: 6E6C696E 650D0A52 6F757465 723E0D0A            nlin e..R oute r>..
00000620: 526F7574 65723E65 6E0D0A52 6F757465             Rout er>e n..R oute
00000630: 72237368 206D6F64 20310D0A 4D6F6420             r#sh mod 1.. Mod
00000640: 506F7274 73204361 72642054 79706520               Port s Ca rd T ype
00000650: 20202020 20202020 20202020 20202020
00000660: 20202020 20202020 20202020 204D6F64              Mod
00000670: 656C2020 20202020 20202020 20202020              el
00000680: 53657269 616C204E 6F2E0D0A 2D2D2D20           Seri al N o…

Yep that is hex.  And the logs are to the right side of the hex code.

How to attach to the 6800ia

With version XXX you are not able to attach to the console port of a 6800ia once it is registered with the 6880.

NOTE:  You should only do this for advanced troubleshooting.  NO CONFIGURATIONS SHOULD BE MADE DIRECTLY ON THE 6800ia.

Use the “attach fex #” command

#attach fex 103

Attach FEX:103 ip:192.1.1.103
Trying 192.1.1.103 … Open
▒▒▒▒▒▒▒▒

User Access Verification

Password: //Note that I did not know the default password
Password:
Password: // cisco is the password
FEX-103>en
Password: // cisco is the password
FEX-103#

Quit takes you back to the 6880 command line

#quit
[Connection to 192.1.1.103 closed by foreign host]

Cisco 6880 and 6800ia

Weird issue with 6880 running VSS and 6800ia’s not registering.

6880 config 

fex 120
description Core120-Stack
!
interface Port-channel120
switchport
switchport mode fex-fabric
fex associate 120
!
interface TenGigabitEthernet1/5/10
switchport
switchport mode fex-fabric
channel-group 120 mode on
!
interface TenGigabitEthernet2/5/10
switchport
switchport mode fex-fabric
channel-group 120 mode on

Error seen on the 6880 
%SATMGR-SW1-3-IMGCHECK_ERROR: Packaged image for FEX model C6800IA-48FPDR unknown: unable to check FEX 120 image

IOS version
sho ver
Cisco IOS Software, c6880x Software (c6880x-IPSERVICESK9-M), Version 15.1(2)SY2, RELEASE SOFTWARE (fc3)

sho fex 120 detail
FEX: 120 Description: Core110-stack state: registration
FEX version: 15.0(2)EX6
Extender Model: C6800IA-48FPDR, Extender Serial: Fxxxxx
FCP ready: no
Image Version Check: enforced
Fabric Portchannel Ports: 1
Fabric port for control traffic: Te1/5/10
Fabric interface state:
Po110 – Interface Up.
Te1/5/10 – Interface Up. state: bound
Te2/5/10 – Interface Up. state: tx

Solution:
Upgrade the 6880 code to:
sho ver
Cisco IOS Software, c6880x Software (c6880x-IPSERVICESK9-M), Version 15.1(2)SY3, RELEASE SOFTWARE (fc4)

sho fex 120 det
FEX: 120 Description: Core120-Stack state: online
FEX version: 15.0(2)EX6
Extender Model: C6800IA-48FPDR, Extender Serial: Fxxxxxxx
FCP ready: yes
Image Version Check: enforced
Fabric Portchannel Ports: 2
Fabric port for control traffic: Te2/5/10
Fabric interface state:
Po120 – Interface Up.
Te1/5/10 – Interface Up. state: bound
Te2/5/10 – Interface Up. state: bound